栃木県のJavaエンジニア、WEBプログラマーのためのサイト

2017.01.05[Swift] CocoaPods で管理しているライブラリを Swift 2.3 でビルド

Podfile

Xcode 8 から Swift のバージョンが 2.3 または 3.0 となりました。
CocoaPods で管理しているライブラリでも、Swift のバージョンを指定しないといけない場合があります。
Podfile に、以下を追記して Swift のバージョンを指定することが可能です。

post_install do |installer|
    installer.pods_project.targets.each do |target|
        target.build_configurations.each do |config|
            config.build_settings['SWIFT_VERSION'] = '2.3'
        end
    end
end

※ 導入するライブラリのバージョンも Swift 2.3 対応のものを指定する必要があります。